
GETTING STARTED GUIDE

NI-DAQ mx Base 1.0 
This guide describes how to install and configure the NI-DAQmx Base 1.0 
for Pocket PC driver software and a data acquisition (DAQ) device. This 
guide also describes how to verify that the device is operating properly. 
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Conventions
The following conventions are used in this guide.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash. When this symbol is marked on 
the device, refer to the Read Me First: Safety and Radio-Frequency 
Interference document, shipped with the device, for precautions to take.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. 

italic Italic text denotes a cross reference, an introduction to a key concept, or a 
placeholder for a word or value that you must supply.

monospace Text in this font denotes text or characters you should enter from the 
keyboard, the proper names of disk drives, paths, directories, programs, 
functions, filenames, and extensions.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.



© National Instruments Corporation 3 NI-DAQmx Base Getting Started Guide

Related Documentation
The following documents contain information you might find helpful as 
you read this manual:

• NI-DAQmx Base Help

• NI-DAQmx Base 1.0 Readme

• NI-DAQmx Help

• Getting Started with the LabVIEW PDA Module

• LabVIEW PDA Module User Manual

• LabVIEW PDA Module Release Notes

• LabVIEW Help, available by selecting Help»VI, Function, & 
How-To Help

• LabVIEW User Manual, available in PDF format by selecting 
Start»Programs»National Instruments»LabVIEW 7.1»Search the 
LabVIEW Bookshelf and clicking the LabVIEW User Manual link

• E Series Help

• Documentation for the Personal Digital Assistant (PDA) device 
you use

Overview
National Instruments measurement devices are packaged with 
NI-DAQ driver software, an extensive library of functions and VIs 
which you can call from your application software, such as LabVIEW or 
LabWindows™/CVI™, to program all the features of your NI measurement 
devices. Driver software has an application programming interface (API), 
which is a library of VIs, functions, classes, attributes, and properties for 
creating applications for your device.

There are three drivers associated with NI-DAQ driver software: 
Traditional NI-DAQ, NI-DAQmx, and NI-DAQmx Base.

Traditional NI-DAQ
Traditional NI-DAQ 7.x is an upgrade to the earlier version of NI-DAQ. 
Traditional NI-DAQ has the same VIs and functions and works the same 
way as NI-DAQ 6.9.3, except that you can use Traditional NI-DAQ and 
NI-DAQmx on the same computer.
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NI-DAQmx
NI-DAQmx 7.x is the latest NI-DAQ driver with the following advantages 
over Traditional NI-DAQ:

• DAQ Assistant, which offers a graphical way to configure channels 
and measurement tasks for your device, and to generate NI-DAQmx 
code based on your channels and tasks in LabVIEW.

• Increased performance, including faster single-point analog I/O and 
multithreading.

• Simpler, more intuitive APIs for creating DAQ applications using 
fewer functions and VIs than earlier versions of NI-DAQ.

• Expanded functionality for LabVIEW, including property nodes and 
waveform data type support.

NI-DAQmx Base
NI-DAQmx Base is a driver that allows you to build applications that run 
on a PDA. NI-DAQmx Base includes the following features:

• NI-DAQmx Base provides a high-level interface on LabVIEW PDA 
for Pocket PC 2003.

• NI-DAQmx Base is a subset of the NI-DAQmx API. If you are familiar 
with NI-DAQmx, you should be able to comfortably use NI-DAQmx 
Base.

• NI-DAQmx Base is comprised of LabVIEW VIs, which allows you to 
customize the driver, if needed.

Refer to the NI-DAQmx Base Readme for more information about the 
differences between NI-DAQmx Base and NI-DAQmx.

Step 1. Confirm That You Have Installed the Correct 
Application Software Version

Install LabVIEW 7.1 or later and LabVIEW PDA Module 7.1 or later. You 
must use LabVIEW 7.1 or later with NI-DAQmx Base 1.0 for Pocket PC. 
Refer to the Operating System, Application Software, Programming 
Language, and Device Support in NI-DAQmx Base 1.0 section at the end 
of this guide for more information. Also, refer to Getting Started with the 
LabVIEW PDA Module and the LabVIEW PDA Module User Manual for 
more information.

Note Be sure LabVIEW PDA is completely installed and configured before continuing.
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Step 2. Install the NI-DAQmx Base Software
The following sections describe how to install the NI-DAQmx Base 
software.

Insert the CD
Inserting the CD launches the NI-DAQmx Base install window.

If the NI-DAQmx Base install window does not open automatically, 
complete the following steps:

1. Select Start»Run. 

2. Enter x:\setup.exe, where x is the letter of the CD drive. 

3. Click Install NI-DAQmx Base 1.0.

Install Support Files
The NI-DAQmx Base installer detects the NI software installed on the 
operating system and automatically selects the latest versions of the driver, 
application software, and language support files from the CD.

The NI-DAQmx Base installer displays which features will be installed to 
your operating system, as shown.



NI-DAQmx Base Getting Started Guide 6 ni.com

Complete the following steps to install NI-DAQmx Base 1.0 for Pocket PC:

1. In the Features window, shown in the previous figure, verify that the 
installer detected and selected the correct support files and the correct 
version number of the application software.

2. Click the + in front of the feature to expand the list of feature 
subcomponents as shown in the previous figure. You can select 
additional options to install the support files, examples, and 
documentation.

3. Follow the software prompts.

4. Click Finish and wait for the installer to complete. NI-DAQmx 
Base 1.0 might require you to reboot your computer to complete 
installation.

You have completed the steps to install NI-DAQmx Base 1.0 for Pocket PC 
on the Windows host platform. 

Step 3. Run the PDA Setup Utility (Pocket PC 2003 only)
After running the NI-DAQmx Base installation, you must copy the driver 
files to the PDA. Complete the following steps to run the Pocket PC Driver 
Installation utility:

1. Select Start»Programs»National Instruments»NI-DAQmx Base.

2. Click PocketPC Driver Installation. This launches the Pocket PC 
ADD/Remove Programs utility window, as shown in the following 
figure.
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3. Click Yes to install the device driver into the default application install 
directory.

4. Check the Pocket PC screen to see if any additional steps are requested, 
such as replacing an older driver.

If there are no error messages, you have completed the steps to install the 
driver files onto the PDA.

Step 4. Unpack the Devices, Accessories, and Cables
Your device ships in an antistatic package to prevent electrostatic damage 
(ESD) to the device. ESD can damage several components on the device. 

Caution Never touch the exposed pins of connectors.

To avoid such damage, take the following precautions:

• Ground yourself using a grounding strap or by touching a grounded 
object. 

• Touch the antistatic package to a metal part of the computer chassis 
before removing the device from the package.
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Remove the device from the package and inspect the device for loose 
components or any sign of damage. Notify NI if the device appears 
damaged in any way. Do not install a damaged device in the computer, 
PDA, or PXI chassis.

Store the device in the antistatic package when the device is not in use.

For safety and compliance information, refer to the device documentation 
packaged with your device, or on the Device Document Browser in the 
NI-DAQ software kit.

Step 5. Install the Devices, Accessories, and Cables
The following section discusses how to install the NI PCMCIA device and 
the I/O cable.

PCMCIA Device Installation

Caution Follow proper ESD precautions to ensure you are grounded before installing the 
hardware.

The PCMCIA device supports hot insertion on the PDA, which means the 
PCMCIA device can be installed and removed without rebooting the PDA. 
You can install an NI PCMCIA device in any available Type II PC Card 
slot. 
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To install the NI PCMCIA device, refer to the following figure and 
complete the following steps.

1. Attach the PCMCIA sleeve or expansion pack to the PDA, if necessary.

2. NI PCMCIA devices have two connectors: a 68-pin PCMCIA bus 
connector on one end and an I/O connector on the other end. The 
NI PCMCIA device is keyed so that you can insert it only one way. 
Insert the PCMCIA bus connector of the NI PCMCIA device in the 
slot until the connector is firmly seated.

3. Attach the I/O cable. Be careful not to put strain on the I/O cable when 
inserting or removing the cable connector. 

Caution Always grasp the cable by the connector you are inserting or removing. 
Never pull directly on the I/O cable to unplug it from the NI PCMCIA device.

You have completed the steps to install the NI PCMCIA device.

Accessories
Install accessories and/or terminal blocks according to the instructions in 
their user guides.

1 PDA with PCMCIA Slot
2 PCMCIA Socket
3 PDA Expansion Pack
4 NI PCMCIA Device

5 I/O Cable
6 Accessory
7 I/O Signals

®

1

2
5

6

DAQCard-6062

7

4

3



NI-DAQmx Base Getting Started Guide 10 ni.com

Step 6. Confirm That Your Device Is Recognized
Pocket PC only indicates whether a hardware installation error occurred. 
If you receive an unknown device error message, you have not correctly 
installed NI-DAQmx Base 1.0 for Pocket PC on the PDA. Refer to Step 2. 
Install the NI-DAQmx Base Software for more information about how to 
install the Pocket PC features of the NI-DAQmx Base driver. If there are 
no error messages, you have successfully installed the features and the 
device is recognized by the NI-DAQmx Base 1.0 driver.

Step 7. Create and Configure Tasks
A task, an important concept for NI-DAQmx and NI-DAQmx Base, is a 
collection of one or more channels with timing, triggering, and other 
properties. Conceptually, a task represents a measurement or generation 
you want to perform. You can set up and save all configuration information 
in a task and use the task in an application.

Currently, NI-DAQmx Base only supports interactive task configuration. 
Settings such as channel gain, trigger levels, and terminal configuration, 
cannot be programmatically set and must be statically configured as part of 
the task. However, you can create multiple tasks, each with a unique 
configuration, and switch between them in your application.
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Using the NI-DAQmx Base Configuration Utility in NI-DAQmx Base
In NI-DAQmx Base 1.0 for Pocket PC, task information is embedded in the 
built application. Prior to building and downloading your VI to the PDA, 
you must configure and save the tasks you want to use. To configure and 
save your tasks, use the Task Configuration utility included with 
NI-DAQmx Base. To use the Task Configuration Utility, complete the 
following steps:

1. Select Start»Programs»National Instruments»NI-DAQmx Base. 

2. Click NI-DAQmx Base Task Configuration Utility. The Task 
Configuration Utility launches.

Note You also can launch the Task Configuration Utility from within LabVIEW by 
selecting Tools»NI-DAQmx Base Task Configuration Utility.
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Create, Modify, and Configure a Task In NI-DAQmx
Create a new task or modify one of the existing ones in the Task 
Configuration Utility task list. The pre-installed tasks are configured to 
work with the examples without modifications. To modify an existing task, 
select it in the task list. Complete the following steps to create a new task:

1. Click Create New Task. The Create New Task.vi window opens.

2. Enter a name for the new task.

3. Select the acquisition type.

4. Select the device. For NI PCMCIA devices on Pocket PC 2003, select 
the device that matches your installed hardware.

Each acquisition type contains a set of tabbed dialog boxes for configuring 
the task.
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Tip You can view context help for the Task Configuration Utility by pressing <Ctrl-H>.

5. Click Exit when you are finished configuring your tasks. The task 
configuration is automatically saved into LabVIEW global variables. 
You do not need to explicitly save the configuration.

To transfer the task configuration to other computers, click Export 
Configuration and save the tasks to a file. You then can use Import 
Configuration to import the task configuration.

Notes The Import Configuration and Export Configuration options operate on the entire 
set of tasks shown in the Task Configuration Utility. Importing a configuration will replace 
any existing tasks, including the predefined tasks for the example process.

When using LabVIEW for Pocket PC 2003, the task configuration is built into the target 
application. You cannot retrieve the task information after it is embedded in a built 
application. Exporting the configuration allows you to preserve the task in case of 
accidental deletion in the Task Configuration Utility.

Using Tasks In An Application
Because NI-DAQmx Base currently supports interactive task configuration 
only, you must use a task control or constant in your application to specify 
the configuration to use. 

Complete the following steps to create a task control or constant:

1. Right-click the task/channels in terminal on a NI-DAQmx Base VI.

2. Select Create»Control or Create»Constant. 

3. Type the name of the task in the control or constant.

4. To set the value as the default for the control, right-click the control and 
select Data Operations»Make Current Value Default.

Documentation
The NI-DAQmx Base software kit includes online documentation for 
supported devices and accessories, including PDF and help files describing 
device terminals, specifications, features, and operation.

After installation, the documents are accessible from Start»Programs»
National Instruments»NI-DAQmx Base»Documentation.

Note You must have Internet Explorer version 5.0 or later to use some features of the 
NI-DAQmx Base 7.x documentation, including the help system.
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Getting Started Developing an Application

Examples
NI-DAQmx Base includes a collection of programming examples to help 
you get started developing an application. You can modify example code 
and save it in an application. You can use examples to develop a new 
application or add example code to an existing application.

NI-DAQmx Base examples for LabVIEW are in the LabVIEW\
examples\DAQmxBase directory.

The following figure illustrates a typical NI-DAQmx Base application 
which uses a preconfigured task to acquire and display a finite number of 
points for multiple channels.

Refer to Getting Started with the LabVIEW PDA Module and the LabVIEW 
PDA Module User Manual for more information about how to create a PDA 
application.

Obtaining Information about Measurement Applications and Devices
Each application software package and driver includes information about 
writing applications for taking measurements and controlling measurement 
devices. The following references assume you have NI-DAQmx Base and, 
where applicable, LabVIEW 7.1 installed on your computer.
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LabVIEW
If you are a new user, complete Getting Started with LabVIEW to 
get acquainted with LabVIEW. Select Start»Programs»National 
Instruments»LabVIEW»Search the LabVIEW Bookshelf.

The LabVIEW NI-DAQmx Base VI Reference Help describes the LabVIEW 
VIs and properties. In LabVIEW, select Help»LabVIEW Help and the VI 
reference help section for NI-DAQmx Base.

Training Courses
National Instruments offers training courses for those interested in 
receiving more help developing an application with NI products. To enroll 
in a course or obtain a detailed course outline, refer to ni.com/training. 

Worldwide Technical Support
For additional support, refer to ni.com/support or ni.com/zone. 

For further support information for signal conditioning products, refer 
to the Signal Conditioning Technical Support Information document 
packaged with your device.

National Instruments corporate headquarters is located at 11500 North 
Mopac Expressway, Austin, Texas, 78759-3504. National Instruments also 
has offices located around the world to help address your support needs.

Using NI-DAQmx Base and NI-DAQmx on the 
Same Computer

You can run NI-DAQmx Base and NI-DAQmx on the same computer. 
However, NI-DAQmx Base 1.0 is specifically designed for use with 
LabVIEW PDA and Pocket PC 2003.
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Operating System, Application Software, Programming 
Language, and Device Support in NI-DAQmx Base 1.0

Operating System Support
NI-DAQmx Base 1.0 supports Pocket PC 2003 with LabVIEW 7.1 PDA. 
The development environment runs in LabVIEW 7.1 and is supported on 
Windows 2000/XP.

Device Support
NI-DAQmx Base 1.0 supports the following devices:

• NI DAQCard-6024E for PCMCIA

• NI DAQCard-6062E for PCMCIA

Note For specific device model names or a list of newly supported devices, refer to the 
NI-DAQmx Base 1.0 Readme on the CD, or selectr Start»Programs»
National Instruments»NI-DAQmx Base.
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